Hi Daniel,

Nice piece of software you have developed. Very much appreciated. I just wanted to comment that I wasted a few hours trying to get your software working on two different servers. In the end, the problem was that in:

restifydb-1.1.0/restifydb/restify/bootstrap.php

you have disabled error reporting:

error_reporting(0);

This meant that I couldn't figure out why the application wouldn't load. Setting this command to:

error_reporting(E_ALL);

got me going. I didn't expect your application to do this so I wasted a lot of time trying to figure out what was going on.

On my FreeBSD system, I had to install:

pkg install php56-pdo_sqlite php56-pdo_mysql

before the application would successfully load.

Could you please not disable error reporting for new installations because it makes fault finding impossible... Also, could you point out in the documentation that the PDO extensions for PHP must be installed before the application will load?

Brad

Hi Daniel, Nice piece of software you have developed. Very much appreciated. I just wanted to comment that I wasted a few hours trying to get your software working on two different servers. In the end, the problem was that in: ```` restifydb-1.1.0/restifydb/restify/bootstrap.php ```` you have disabled error reporting: ```` error_reporting(0); ```` This meant that I couldn't figure out why the application wouldn't load. Setting this command to: ```` error_reporting(E_ALL); ```` got me going. I didn't expect your application to do this so I wasted a lot of time trying to figure out what was going on. On my FreeBSD system, I had to install: ```` pkg install php56-pdo_sqlite php56-pdo_mysql ```` before the application would successfully load. Could you please not disable error reporting for new installations because it makes fault finding impossible... Also, could you point out in the documentation that the PDO extensions for PHP must be installed before the application will load? Brad

Hey Brad,

Your are absolutely right, I will specify that the pdo_sqlite module needs to be installed as well. Thanks for pointing this out.

Best regards,
Daniel

Hey Brad, Your are absolutely right, I will specify that the pdo_sqlite module needs to be installed as well. Thanks for pointing this out. Best regards, Daniel
239
views
1
replies
2
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
All posts under this topic will be deleted ?
Powered by Codoforum
Pending draft ... Click to resume editing
Discard draft